What’s Vulnerable › Vulnerabilities
CVE-2022-23058: ERPNext - Stored XSS in My Settings
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-22 · updated 2026-06-17
- Weakness: CWE-79
Description
ERPNext in versions v12.0.9-v13.0.3 are affected by a stored XSS vulnerability that allows low privileged users to store malicious scripts in the ‘username’ field in ‘my settings’ which can lead to full account takeover.
Affected products
- frappe erpnext: from 12.0.9 before 13.1.0 — fixed in 13.1.0
How to fix
Upgrade to a fixed version: frappe erpnext 13.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7
- https://www.mend.io/vulnerability-database/CVE-2022-23058
- https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7
- https://www.mend.io/vulnerability-database/CVE-2022-23058
Get alerted when CVE-2022-23058 or the next vulnerability affects your stack