What’s Vulnerable › Vulnerabilities
CVE-2022-2306: Insufficient Session Expiration in heroiclabs/nakama
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-05 · updated 2026-06-17
- Weakness: CWE-613
Description
Old session tokens can be used to authenticate to the application and send authenticated requests.
Affected products
- heroiclabs/nakama: before 3.13.0 — fixed in 3.13.0
How to fix
Upgrade to a fixed version: heroiclabs/nakama 3.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/heroiclabs/nakama/commit/ce8d3921e2acd44ef8b5e6edfe595b6df067b166
- https://huntr.dev/bounties/35acf263-6db4-4310-ab27-4c3c3a53f796
- https://github.com/heroiclabs/nakama/commit/ce8d3921e2acd44ef8b5e6edfe595b6df067b166
- https://huntr.dev/bounties/35acf263-6db4-4310-ab27-4c3c3a53f796
Get alerted when CVE-2022-2306 or the next vulnerability affects your stack