What’s Vulnerable › Vulnerabilities

CVE-2022-23094

Description

Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state object exists. This is fixed in 4.6.

Affected products

How to fix

Upgrade to a fixed version: The Libreswan Project libreswan 4.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-23094 or the next vulnerability affects your stack