What’s Vulnerable › Vulnerabilities
CVE-2022-2310: Skyhigh SWG Authentication bypass vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-27 · updated 2026-06-17
- Weakness: CWE-290
Description
An authentication bypass vulnerability in Skyhigh SWG in main releases 10.x prior to 10.2.12, 9.x prior to 9.2.23, 8.x prior to 8.2.28, and controlled release 11.x prior to 11.2.1 allows a remote attacker to bypass authentication into the administration User Interface. This is possible because of SWG incorrectly whitelisting authentication bypass methods and using a weak crypto password. This can lead to the attacker logging into the SWG admin interface, without valid credentials, as the super user with complete control over the SWG.
Affected products
- Skyhigh Security Skyhigh Secure Web Gateway (SWG): from 8.0.0 before 8.2.28; from 9.0.0 before 9.2.23; from 10.0.0 before 10.2.12; from 11.0.0 before 11.2.1 — fixed in 10.2.12, 11.2.1, 8.2.28, 9.2.23
How to fix
Upgrade to a fixed version: Skyhigh Security Skyhigh Secure Web Gateway (SWG) 10.2.12, 11.2.1, 8.2.28, 9.2.23. Check the vendor advisory for mitigations.
References
- https://kcm.trellix.com/corporate/index?page=content&id=SB10384&actp=null&viewlocale=en_US&showDraft=false&platinum_status=false&locale=en_US
- https://kcm.trellix.com/corporate/index?page=content&id=SB10384&actp=null&viewlocale=en_US&showDraft=false&platinum_status=false&locale=en_US
Get alerted when CVE-2022-2310 or the next vulnerability affects your stack