What’s Vulnerable › Vulnerabilities
CVE-2022-23107
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-12 · updated 2026-06-17
- Weakness: CWE-22
Description
Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
Affected products
- Jenkins project Jenkins Warnings Next Generation Plugin: from 9.0.0 before 9.0.2; from 9.5.0 before 9.5.2; from 9.10.0 through 9.10.2; 9.7.0 — fixed in 9.0.2, 9.5.2
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Warnings Next Generation Plugin 9.0.2, 9.5.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/12/6
- https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2090
- http://www.openwall.com/lists/oss-security/2022/01/12/6
- https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2090
Get alerted when CVE-2022-23107 or the next vulnerability affects your stack