What’s Vulnerable › Vulnerabilities
CVE-2022-23120
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-20 · updated 2026-06-17
- Weakness: CWE-94
Description
A code injection vulnerability in Trend Micro Deep Security and Cloud One - Workload Security Agent for Linux version 20 and below could allow an attacker to escalate privileges and run arbitrary code in the context of root. Please note: an attacker must first obtain access to the target agent in an un-activated and unconfigured state in order to exploit this vulnerability.
Affected products
- Trend Micro Deep Security: from 20.0 before 20.0.0-3445; 10.0, 10.0-update1, 10.0-update10, 10.0-update11, 10.0-update12, 10.0-update13 (+76) — fixed in 20.0.0-3445
How to fix
Upgrade to a fixed version: Trend Micro Deep Security 20.0.0-3445. Check the vendor advisory for mitigations.
References
- https://success.trendmicro.com/solution/000290104
- https://www.modzero.com/advisories/MZ-21-02-Trendmicro.txt
- https://success.trendmicro.com/solution/000290104
- https://www.modzero.com/advisories/MZ-21-02-Trendmicro.txt
Get alerted when CVE-2022-23120 or the next vulnerability affects your stack