What’s Vulnerable › Vulnerabilities
CVE-2022-2318
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-06 · updated 2026-06-17
- Weakness: CWE-416
Description
There are use-after-free vulnerabilities caused by timer handler in net/rose/rose_timer.c of linux that allow attackers to crash linux kernel without any privileges.
Affected products
- Debian Linux: 10.0, 11.0
- Linux kernel: before 5.19; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4 — fixed in 5.19
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.19. Check the vendor advisory for mitigations.
References
- https://github.com/torvalds/linux/commit/9cc02ede696272c5271a401e4f27c262359bc2f6
- https://lists.debian.org/debian-lts-announce/2022/10/msg00000.html
- https://security.netapp.com/advisory/ntap-20230120-0001/
- https://www.debian.org/security/2022/dsa-5191
- https://github.com/torvalds/linux/commit/9cc02ede696272c5271a401e4f27c262359bc2f6
- https://lists.debian.org/debian-lts-announce/2022/10/msg00000.html
- https://security.netapp.com/advisory/ntap-20230120-0001/
- https://www.debian.org/security/2022/dsa-5191
Get alerted when CVE-2022-2318 or the next vulnerability affects your stack