What’s Vulnerable › Vulnerabilities
CVE-2022-23187: Adobe Illustrator 2022 Buffer Overflow could lead to Arbitrary code execution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-120
Description
Adobe Illustrator version 26.0.3 (and earlier) is affected by a buffer overflow vulnerability due to insecure handling of a crafted file, potentially resulting in arbitrary code execution in the context of the current user. Exploitation requires user interaction in that a victim must open a crafted file in Illustrator.
Affected products
- Adobe Illustrator: from 25.0 before 25.4.5; from 26.0 before 26.1.0 — fixed in 25.4.5, 26.1.0
How to fix
Upgrade to a fixed version: Adobe Illustrator 25.4.5, 26.1.0. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/illustrator/apsb22-15.html
- https://helpx.adobe.com/security/products/illustrator/apsb22-15.html
Get alerted when CVE-2022-23187 or the next vulnerability affects your stack