What’s Vulnerable › Vulnerabilities
CVE-2022-23218
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-14 · updated 2026-10-14
- Weakness: CWE-120
Description
The deprecated compatibility function svcunix_create in the sunrpc module of the GNU C Library (aka glibc) through 2.34 copies its path argument on the stack without validating its length, which may result in a buffer overflow, potentially resulting in a denial of service or (if an application is not built with a stack protector enabled) arbitrary code execution.
Affected products
- Debian Linux: 10.0
- GNU C Library (glibc): before 2.31 — fixed in 2.31
- Oracle Communications Cloud Native Core Unified Data Repository: 22.2.0
- Oracle Enterprise Operations Monitor: 4.3, 4.4, 5.0
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.31. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2022/10/msg00021.html
- https://security.gentoo.org/glsa/202208-24
- https://sourceware.org/bugzilla/show_bug.cgi?id=28768
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://lists.debian.org/debian-lts-announce/2022/10/msg00021.html
- https://security.gentoo.org/glsa/202208-24
- https://sourceware.org/bugzilla/show_bug.cgi?id=28768
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://cert-portal.siemens.com/productcert/html/ssa-099606.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-831302.html
Get alerted when CVE-2022-23218 or the next vulnerability affects your stack