What’s Vulnerable › Vulnerabilities
CVE-2022-23220
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-21 · updated 2026-06-17
- Weakness: CWE-306
Description
USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.
Affected products
- Usbview Project Usbview: before 2.2 — fixed in 2.2
How to fix
Upgrade to a fixed version: Usbview Project Usbview 2.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/22/1
- https://github.com/gregkh/usbview/commit/bf374fa4e5b9a756789dfd88efa93806a395463b
- https://security.gentoo.org/glsa/202310-15
- https://www.debian.org/security/2022/dsa-5052
- https://www.openwall.com/lists/oss-security/2022/01/21/1
- http://www.openwall.com/lists/oss-security/2022/01/22/1
- https://github.com/gregkh/usbview/commit/bf374fa4e5b9a756789dfd88efa93806a395463b
- https://security.gentoo.org/glsa/202310-15
- https://www.debian.org/security/2022/dsa-5052
- https://www.openwall.com/lists/oss-security/2022/01/21/1
Get alerted when CVE-2022-23220 or the next vulnerability affects your stack