What’s Vulnerable › Vulnerabilities
CVE-2022-23302: Deserialization of untrusted data in JMSSink in Apache Log4j 1.x
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-18 · updated 2026-06-17
- Weakness: CWE-502
Description
JMSSink in all versions of Log4j 1.x is vulnerable to deserialization of untrusted data when the attacker has write access to the Log4j configuration or if the configuration references an LDAP service the attacker has access to. The attacker can provide a TopicConnectionFactoryBindingName configuration causing JMSSink to perform JNDI requests that result in remote code execution in a similar fashion to CVE-2021-4104. Note this issue only affects Log4j 1.x when specifically configured to use JMSSink, which is not the default. Apache Log4j 1.2 reached end of life in August 2015. Users should upgrade to Log4j 2 as it addresses numerous other issues from the previous versions.
Affected products
- Apache Log4j: from 1.0.1 through 1.2.17
- Brocade SANnav: all versions
- SnapManager for Oracle: all versions
- Oracle Corporation Oracle Advanced Supply Chain Planning: 12.1, 12.2
- Oracle Corporation Oracle Business Intelligence Enterprise Edition: 5.9.0.0.0, 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle Business Process Management Suite: 12.2.1.3.0, 12.2.1.4.0
- Oracle Communications Eagle Ftp Table Base Retrieval: 4.5
- Oracle Communications Instant Messaging Server: 10.0.1.5.0
- Oracle Communications Messaging Server: 8.1
- Oracle Communications Network Integrity: 7.3.6
- Oracle Communications Offline Mediation Controller: before 12.0.0.4.4; 12.0.0.5.0 — fixed in 12.0.0.4.4
- Oracle Corporation Oracle Communications Unified Inventory Management: 7.4.1, 7.4.2
- Oracle E-Business Suite Cloud Manager And Cloud Backup Module: before 2.2.1.1.1; 2.2.1.1.1 — fixed in 2.2.1.1.1
- Oracle Corporation Enterprise Manager Base Platform: 13.4.0.0, 13.5.0.0
- Oracle Financial Services Revenue Management And Billing Analytics: 2.7.0.0, 2.7.0.1, 2.8.0.0
- Oracle Healthcare Foundation: 8.1.0
- Oracle Corporation Oracle Hyperion Data Relationship Management: before 11.2.8.0 — fixed in 11.2.8.0
- Oracle Corporation Oracle Hyperion Infrastructure Technology: before 11.2.8.0 — fixed in 11.2.8.0
- Oracle Identity Management Suite: 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle Identity Manager Connector: 11.1.1.5.0
- Oracle Corporation Oracle JDeveloper: 12.2.1.3.0
- Oracle Middleware Common Libraries And Tools: 12.2.1.4.0
- Oracle Corporation MySQL Enterprise Monitor: through 8.0.29
- Oracle Corporation Tuxedo: 12.2.2.0.0
- Oracle WebLogic Server: 12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0
- Qos Reload4J: before 1.2.18.1 — fixed in 1.2.18.1
How to fix
Upgrade to a fixed version: Oracle Communications Offline Mediation Controller 12.0.0.4.4; Oracle E-Business Suite Cloud Manager And Cloud Backup Module 2.2.1.1.1; Oracle Corporation Oracle Hyperion Data Relationship Management 11.2.8.0; Oracle Corporation Oracle Hyperion Infrastructure Technology 11.2.8.0; Qos Reload4J 1.2.18.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/18/3
- https://lists.apache.org/thread/bsr3l5qz4g0myrjhy9h67bcxodpkwj4w
- https://logging.apache.org/log4j/1.2/index.html
- https://security.netapp.com/advisory/ntap-20220217-0006/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- http://www.openwall.com/lists/oss-security/2022/01/18/3
- https://lists.apache.org/thread/bsr3l5qz4g0myrjhy9h67bcxodpkwj4w
- https://logging.apache.org/log4j/1.2/index.html
- https://security.netapp.com/advisory/ntap-20220217-0006/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
Get alerted when CVE-2022-23302 or the next vulnerability affects your stack