What’s Vulnerable › Vulnerabilities
CVE-2022-23303
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-17 · updated 2026-07-14
- Weakness: CWE-203
Description
The implementations of SAE in hostapd before 2.10 and wpa_supplicant before 2.10 are vulnerable to side channel attacks as a result of cache access patterns. NOTE: this issue exists because of an incomplete fix for CVE-2019-9494.
Affected products
- Fedoraproject Fedora: 35
- w1.fi hostapd: before 2.10 — fixed in 2.10
- Canonical Ltd. wpa_supplicant: before 2.10 — fixed in 2.10
How to fix
Upgrade to a fixed version: w1.fi hostapd 2.10; Canonical Ltd. wpa_supplicant 2.10. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPDHU5MV464CZBPX7N2SNMUYP6DFIBZL/
- https://security.gentoo.org/glsa/202309-16
- https://w1.fi/security/2022-1/
- https://lists.debian.org/debian-lts-announce/2025/04/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPDHU5MV464CZBPX7N2SNMUYP6DFIBZL/
- https://security.gentoo.org/glsa/202309-16
- https://w1.fi/security/2022-1/
- https://cert-portal.siemens.com/productcert/html/ssa-585531.html
Get alerted when CVE-2022-23303 or the next vulnerability affects your stack