What’s Vulnerable › Vulnerabilities
CVE-2022-23317
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-15 · updated 2026-06-17
- Weakness: CWE-287
Description
CobaltStrike <=4.5 HTTP(S) listener does not determine whether the request URL begins with "/", and attackers can obtain relevant information by specifying the URL.
Affected products
- Helpsystems Cobalt Strike: before 4.5 — fixed in 4.5
How to fix
Upgrade to a fixed version: Helpsystems Cobalt Strike 4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-23317 or the next vulnerability affects your stack