What’s Vulnerable › Vulnerabilities
CVE-2022-23408
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-18 · updated 2026-06-17
- Weakness: CWE-330
Description
wolfSSL 5.x before 5.1.1 uses non-random IV values in certain situations. This affects connections (without AEAD) using AES-CBC or DES3 with TLS 1.1 or 1.2 or DTLS 1.1 or 1.2. This occurs because of misplaced memory initialization in BuildMessage in internal.c.
Affected products
- wolfSSL: from 5.0.0 before 5.1.1 — fixed in 5.1.1
How to fix
Upgrade to a fixed version: wolfSSL 5.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/blob/master/ChangeLog.md#wolfssl-release-511-jan-3rd-2022
- https://github.com/wolfSSL/wolfssl/pull/4710
- https://github.com/wolfSSL/wolfssl/blob/master/ChangeLog.md#wolfssl-release-511-jan-3rd-2022
- https://github.com/wolfSSL/wolfssl/pull/4710
Get alerted when CVE-2022-23408 or the next vulnerability affects your stack