What’s Vulnerable › Vulnerabilities
CVE-2022-23410
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-427
Description
AXIS IP Utility before 4.18.0 allows for remote code execution and local privilege escalation by the means of DLL hijacking. IPUtility.exe would attempt to load DLLs from its current working directory which could allow for remote code execution if a compromised DLL would be placed in the same folder.
Affected products
- Axis Communications AB AXIS IP Utility: before 4.18.0 — fixed in 4.18.0
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS IP Utility 4.18.0. Check the vendor advisory for mitigations.
References
- https://www.axis.com/files/tech_notes/CVE-2022-23410.pdf
- https://www.axis.com/files/tech_notes/CVE-2022-23410.pdf
Get alerted when CVE-2022-23410 or the next vulnerability affects your stack