What’s Vulnerable › Vulnerabilities
CVE-2022-2342: Cross-site Scripting (XSS) - Stored in outline/outline
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository outline/outline prior to v0.64.4.
Affected products
- outline: before 0.64.4 — fixed in 0.64.4
How to fix
Upgrade to a fixed version: outline 0.64.4. Check the vendor advisory for mitigations.
References
- https://github.com/outline/outline/commit/85657b7340cdeaa696034f294489df8d6a4914d3
- https://huntr.dev/bounties/b2caceaa-5b28-40ba-9980-70144159efba
- https://github.com/outline/outline/commit/85657b7340cdeaa696034f294489df8d6a4914d3
- https://huntr.dev/bounties/b2caceaa-5b28-40ba-9980-70144159efba
Get alerted when CVE-2022-2342 or the next vulnerability affects your stack