What’s Vulnerable › Vulnerabilities
CVE-2022-2343: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-08 · updated 2026-10-08
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0044.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0044 — fixed in 9.0.0044
How to fix
Upgrade to a fixed version: vim/vim 9.0.0044. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/caea66442d86e7bbba3bf3dc202c3c0d549b9853
- https://huntr.dev/bounties/2ecb4345-2fc7-4e7f-adb0-83a20bb458f5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/caea66442d86e7bbba3bf3dc202c3c0d549b9853
- https://huntr.dev/bounties/2ecb4345-2fc7-4e7f-adb0-83a20bb458f5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2343 or the next vulnerability affects your stack