What’s Vulnerable › Vulnerabilities
CVE-2022-23435
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-19 · updated 2026-06-17
Description
decoding.c in android-gif-drawable before 1.2.24 does not limit the maximum length of a comment, leading to denial of service.
Affected products
- Android-Gif-Drawable Project Android-Gif-Drawable: before 1.2.24 — fixed in 1.2.24
How to fix
Upgrade to a fixed version: Android-Gif-Drawable Project Android-Gif-Drawable 1.2.24. Check the vendor advisory for mitigations.
References
- https://github.com/koral--/android-gif-drawable/commit/9f0f0c89e6fa38548163771feeb4bde84b828887
- https://github.com/koral--/android-gif-drawable/compare/v1.2.23...v1.2.24
- https://github.com/koral--/android-gif-drawable/commit/9f0f0c89e6fa38548163771feeb4bde84b828887
- https://github.com/koral--/android-gif-drawable/compare/v1.2.23...v1.2.24
Get alerted when CVE-2022-23435 or the next vulnerability affects your stack