What’s Vulnerable › Vulnerabilities
CVE-2022-2344: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-08 · updated 2026-10-08
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0045.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0045 — fixed in 9.0.0045
How to fix
Upgrade to a fixed version: vim/vim 9.0.0045. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/baefde14550231f6468ac2ed2ed495bc381c0c92
- https://huntr.dev/bounties/4a095ed9-3125-464a-b656-c31b437e1996
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/baefde14550231f6468ac2ed2ed495bc381c0c92
- https://huntr.dev/bounties/4a095ed9-3125-464a-b656-c31b437e1996
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2344 or the next vulnerability affects your stack