What’s Vulnerable › Vulnerabilities
CVE-2022-23447
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-06-17
- Weakness: CWE-22
Description
An improper limitation of a pathname to a restricted directory ('Path Traversal') vulnerability [CWE-22] in FortiExtender management interface 7.0.0 through 7.0.3, 4.2.0 through 4.2.4, 4.1.1 through 4.1.8, 4.0.0 through 4.0.2, 3.3.0 through 3.3.2, 3.2.1 through 3.2.3, 5.3 all versions may allow an unauthenticated and remote attacker to retrieve arbitrary files from the underlying filesystem via specially crafted web requests.
Affected products
- Fortinet FortiExtender: from 3.2.1 before 3.2.4; from 3.3.0 before 3.3.3; from 4.0.0 before 4.0.3; from 4.1.1 before 4.1.9; from 4.2.0 before 4.2.5; from 7.0.0 before 7.0.4 — fixed in 3.2.4, 3.3.3, 4.0.3, 4.1.9, 4.2.5, 7.0.4
How to fix
Upgrade to a fixed version: Fortinet FortiExtender 3.2.4, 3.3.3, 4.0.3, 4.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-23447 or the next vulnerability affects your stack