What’s Vulnerable › Vulnerabilities
CVE-2022-2345: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-08 · updated 2026-10-08
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0046.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0046 — fixed in 9.0.0046
How to fix
Upgrade to a fixed version: vim/vim 9.0.0046. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/32acf1f1a72ebb9d8942b9c9d80023bf1bb668ea
- https://huntr.dev/bounties/1eed7009-db6d-487b-bc41-8f2fd260483f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/32acf1f1a72ebb9d8942b9c9d80023bf1bb668ea
- https://huntr.dev/bounties/1eed7009-db6d-487b-bc41-8f2fd260483f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2345 or the next vulnerability affects your stack