What’s Vulnerable › Vulnerabilities
CVE-2022-2346
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-02 · updated 2026-06-17
Description
In affected versions of Octopus Deploy it is possible for a low privileged guest user to interact with extension endpoints.
Affected products
- Octopus Deploy Octopus Server: from 2019.4.0 before 2022.4.9997; from 2023.1.4189 before 2023.1.10235; from 2023.2.2028 before 2023.2.10545 — fixed in 2022.4.9997, 2023.1.10235, 2023.2.10545
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.4.9997, 2023.1.10235, 2023.2.10545. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2023/sa2023-10/
- https://advisories.octopus.com/post/2023/sa2023-10/
Get alerted when CVE-2022-2346 or the next vulnerability affects your stack