What’s Vulnerable › Vulnerabilities
CVE-2022-23466: DOM-based cross-site scripting (XSS) in teler dashboard
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
teler is an real-time intrusion detection and threat alert dashboard. teler prior to version 2.0.0-rc.4 is vulnerable to DOM-based cross-site scripting (XSS) in the teler dashboard. When teler requests messages from the event stream on the `/events` endpoint, the log data displayed on the dashboard are not sanitized. This only affects authenticated users and can only be exploited based on detected threats if the log contains a DOM scripting payload. This vulnerability has been fixed on version `v2.0.0-rc.4`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- kitabisa teler: 2.0.0-dev, 2.0.0-rc, 2.0.0-rc2, 2.0.0-rc3
References
- https://github.com/kitabisa/teler/commit/20f59eda2420ac64e29f199a61230a0abc875e8e
- https://github.com/kitabisa/teler/security/advisories/GHSA-xr7p-8q82-878q
- https://github.com/kitabisa/teler/commit/20f59eda2420ac64e29f199a61230a0abc875e8e
- https://github.com/kitabisa/teler/security/advisories/GHSA-xr7p-8q82-878q
Get alerted when CVE-2022-23466 or the next vulnerability affects your stack