What’s Vulnerable › Vulnerabilities
CVE-2022-23467: Out of Bounds Read in OpenRazer Driver
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-125
Description
OpenRazer is an open source driver and user-space daemon to control Razer device lighting and other features on GNU/Linux. Using a modified USB device an attacker can leak stack addresses of the `razer_attr_read_dpi_stages`, potentially bypassing KASLR. To exploit this vulnerability an attacker would need to access to a users keyboard or mouse or would need to convince a user to use a modified device. The issue has been patched in v3.5.1. Users are advised to upgrade and should be reminded not to plug in unknown USB devices.
Affected products
- openrazer: before 3.5.1 — fixed in 3.5.1
How to fix
Upgrade to a fixed version: openrazer 3.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/openrazer/openrazer/commit/33aa7f07d54ae066f201c6d298cb4a2181cb90e6
- https://github.com/openrazer/openrazer/security/advisories/GHSA-39hg-jvc9-fg7h
- https://github.com/openrazer/openrazer/commit/33aa7f07d54ae066f201c6d298cb4a2181cb90e6
- https://github.com/openrazer/openrazer/security/advisories/GHSA-39hg-jvc9-fg7h
- https://lists.debian.org/debian-lts-announce/2025/04/msg00032.html
Get alerted when CVE-2022-23467 or the next vulnerability affects your stack