What’s Vulnerable › Vulnerabilities
CVE-2022-23471: containerd CRI stream server: Host memory exhaustion through terminal resize goroutine leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-07 · updated 2026-06-17
- Weakness: CWE-400
Description
containerd is an open source container runtime. A bug was found in containerd's CRI implementation where a user can exhaust memory on the host. In the CRI stream server, a goroutine is launched to handle terminal resize events if a TTY is requested. If the user's process fails to launch due to, for example, a faulty command, the goroutine will be stuck waiting to send without a receiver, resulting in a memory leak. Kubernetes and crictl can both be configured to use containerd's CRI implementation and the stream server is used for handling container IO. This bug has been fixed in containerd 1.6.12 and 1.5.16. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used and that only trusted users have permissions to execute commands in running containers.
Affected products
- containerd: before 1.5.16; from 1.6.0 before 1.6.12 — fixed in 1.5.16, 1.6.12
How to fix
Upgrade to a fixed version: containerd 1.5.16, 1.6.12. Check the vendor advisory for mitigations.
References
- https://github.com/containerd/containerd/commit/a05d175400b1145e5e6a735a6710579d181e7fb0
- https://github.com/containerd/containerd/security/advisories/GHSA-2qjp-425j-52j9
- https://security.gentoo.org/glsa/202401-31
- https://github.com/containerd/containerd/commit/a05d175400b1145e5e6a735a6710579d181e7fb0
- https://github.com/containerd/containerd/security/advisories/GHSA-2qjp-425j-52j9
- https://security.gentoo.org/glsa/202401-31
Get alerted when CVE-2022-23471 or the next vulnerability affects your stack