What’s Vulnerable › Vulnerabilities
CVE-2022-23484: Integer Overflow in xrdp
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-09 · updated 2026-06-17
- Weakness: CWE-190
Description
xrdp is an open source project which provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP). xrdp < v0.9.21 contain a Integer Overflow in xrdp_mm_process_rail_update_window_text() function. There are no known workarounds for this issue. Users are advised to upgrade.
Affected products
- Debian Linux: 11.0
- neutrinolabs xrdp: before 0.9.21 — fixed in 0.9.21
How to fix
Upgrade to a fixed version: neutrinolabs xrdp 0.9.21. Check the vendor advisory for mitigations.
References
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-rqfx-5fv8-q9c6
- https://www.debian.org/security/2023/dsa-5502
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-rqfx-5fv8-q9c6
- https://www.debian.org/security/2023/dsa-5502
Get alerted when CVE-2022-23484 or the next vulnerability affects your stack