What’s Vulnerable › Vulnerabilities
CVE-2022-23485: Invite code reuse via cookie manipulation in sentry
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-10 · updated 2026-06-17
- Weakness: CWE-269
Description
Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).
Affected products
- getsentry sentry: from 20.6.0 through 22.10.0
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-jv85-mqxj-3f9j
- https://github.com/getsentry/sentry/security/advisories/GHSA-jv85-mqxj-3f9j
Get alerted when CVE-2022-23485 or the next vulnerability affects your stack