What’s Vulnerable › Vulnerabilities
CVE-2022-23486: libp2p-rust denial of service vulnerability from lack of resource management
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-07 · updated 2026-06-17
- Weakness: CWE-400
Description
libp2p-rust is the official rust language Implementation of the libp2p networking stack. In versions prior to 0.45.1 an attacker node can cause a victim node to allocate a large number of small memory chunks, which can ultimately lead to the victim’s process running out of memory and thus getting killed by its operating system. When executed continuously, this can lead to a denial of service attack, especially relevant on a larger scale when run against more than one node of a libp2p based network. Users are advised to upgrade to `libp2p` `v0.45.1` or above. Users unable to upgrade should reference the DoS Mitigation page for more information on how to incorporate mitigation strategies, monitor their application, and respond to attacks: https://docs.libp2p.io/reference/dos-mitigation/.
Affected products
- libp2p js-libp2p: before 0.45.1 — fixed in 0.45.1
How to fix
Upgrade to a fixed version: libp2p js-libp2p 0.45.1. Check the vendor advisory for mitigations.
References
- https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-jvgw-gccv-q5p8
- https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-jvgw-gccv-q5p8
Get alerted when CVE-2022-23486 or the next vulnerability affects your stack