What’s Vulnerable › Vulnerabilities
CVE-2022-23487: libp2p denial of service vulnerability from lack of resource management
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-07 · updated 2026-06-17
- Weakness: CWE-400
Description
js-libp2p is the official javascript Implementation of libp2p networking stack. Versions older than `v0.38.0` of js-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of js-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to update their js-libp2p dependency to `v0.38.0` or greater. There are no known workarounds for this vulnerability.
Affected products
- libp2p js-libp2p: before 0.38.0 — fixed in 0.38.0
How to fix
Upgrade to a fixed version: libp2p js-libp2p 0.38.0. Check the vendor advisory for mitigations.
References
- https://github.com/libp2p/js-libp2p/security/advisories/GHSA-f44q-634c-jvwv
- https://github.com/libp2p/js-libp2p/security/advisories/GHSA-f44q-634c-jvwv
Get alerted when CVE-2022-23487 or the next vulnerability affects your stack