What’s Vulnerable › Vulnerabilities
CVE-2022-23492: go-libp2p denial of service vulnerability from lack of resource management
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-08 · updated 2026-06-17
- Weakness: CWE-400
Description
go-libp2p is the offical libp2p implementation in the Go programming language. Version `0.18.0` and older of go-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of go-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to upgrade their version of go-libp2p to version `0.18.1` or newer. Users unable to upgrade may consult the denial of service (dos) mitigation page for more information on how to incorporate mitigation strategies, monitor your application, and respond to attacks.
Affected products
- libp2p js-libp2p: before 0.18.0 — fixed in 0.18.0
How to fix
Upgrade to a fixed version: libp2p js-libp2p 0.18.0. Check the vendor advisory for mitigations.
References
- https://docs.libp2p.io/reference/dos-mitigation/
- https://github.com/libp2p/go-libp2p/commit/15d7dfbf54264ead8e6f49ca658d79c90635e2de
- https://github.com/libp2p/go-libp2p/security/advisories/GHSA-j7qp-mfxf-8xjw
- https://docs.libp2p.io/reference/dos-mitigation/
- https://github.com/libp2p/go-libp2p/commit/15d7dfbf54264ead8e6f49ca658d79c90635e2de
- https://github.com/libp2p/go-libp2p/security/advisories/GHSA-j7qp-mfxf-8xjw
Get alerted when CVE-2022-23492 or the next vulnerability affects your stack