What’s Vulnerable › Vulnerabilities
CVE-2022-23500: TYPO3 subject to Uncontrolled Recursion resulting in Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-674
Description
TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.
Affected products
- typo3: from 9.0.0 before 9.5.38; from 10.0.0 before 10.4.33; from 11.0.0 before 11.5.20 — fixed in 10.4.33, 11.5.20, 9.5.38
How to fix
Upgrade to a fixed version: typo3 10.4.33, 11.5.20, 9.5.38. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-8c28-5mp7-v24h
- https://github.com/TYPO3/typo3/security/advisories/GHSA-8c28-5mp7-v24h
Get alerted when CVE-2022-23500 or the next vulnerability affects your stack