What’s Vulnerable › Vulnerabilities

CVE-2022-23501: TYPO3 vulnerable to Improper Authentication in Frontend Login

Description

TYPO3 is an open source PHP based web content management system. In versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 TYPO3 is vulnerable to Improper Authentication. Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Affected products

How to fix

Upgrade to a fixed version: typo3 10.4.33, 11.5.20, 12.1.1, 8.7.49. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-23501 or the next vulnerability affects your stack