What’s Vulnerable › Vulnerabilities
CVE-2022-23502: TYPO3 contains Insufficient Session Expiration after Password Reset
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-613
Description
TYPO3 is an open source PHP based web content management system. In versions prior to 10.4.33, 11.5.20, and 12.1.1, When users reset their password using the corresponding password recovery functionality, existing sessions for that particular user account were not revoked. This applied to both frontend user sessions and backend user sessions. This issue is patched in versions 10.4.33, 11.5.20, 12.1.1.
Affected products
- typo3: from 10.0.0 before 10.4.33; from 11.0.0 before 11.5.20; from 12.0.0 before 12.1.1 — fixed in 10.4.33, 11.5.20, 12.1.1
How to fix
Upgrade to a fixed version: typo3 10.4.33, 11.5.20, 12.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-mgj2-q8wp-29rr
- https://github.com/TYPO3/typo3/security/advisories/GHSA-mgj2-q8wp-29rr
Get alerted when CVE-2022-23502 or the next vulnerability affects your stack