What’s Vulnerable › Vulnerabilities
CVE-2022-23504: TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-200
Description
TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
Affected products
- typo3: from 9.0.0 before 9.5.38; from 10.0.0 before 10.4.33; from 11.0.0 before 11.5.20; from 12.0.0 before 12.1.1 — fixed in 10.4.33, 11.5.20, 12.1.1, 9.5.38
How to fix
Upgrade to a fixed version: typo3 10.4.33, 11.5.20, 12.1.1, 9.5.38. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-8w3p-qh3x-6gjr
- https://github.com/TYPO3/typo3/security/advisories/GHSA-8w3p-qh3x-6gjr
Get alerted when CVE-2022-23504 or the next vulnerability affects your stack