What’s Vulnerable › Vulnerabilities
CVE-2022-23507: Light client verification not taking into account chain ID
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-15 · updated 2026-06-17
- Weakness: CWE-347
Description
Tendermint is a high-performance blockchain consensus engine for Byzantine fault tolerant applications. Versions prior to 0.28.0 contain a potential attack via Improper Verification of Cryptographic Signature, affecting anyone using the tendermint-light-client and related packages to perform light client verification (e.g. IBC-rs, Hermes). The light client does not check that the chain IDs of the trusted and untrusted headers match, resulting in a possible attack vector where someone who finds a header from an untrusted chain that satisfies all other verification conditions (e.g. enough overlapping validator signatures) could fool a light client. The attack vector is currently theoretical, and no proof-of-concept exists yet to exploit it on live networks. This issue is patched in version 0.28.0. There are no workarounds.
Affected products
- Tendermint-Light-Client-Js Project Tendermint-Light-Client-Js: before 0.28.0 — fixed in 0.28.0
- Tendermint-Light-Client-Verifier Project Tendermint-Light-Client-Verifier: before 0.28.0 — fixed in 0.28.0
- Tendermint-Light-Client Project Tendermint-Light-Client: before 0.28.0 — fixed in 0.28.0
How to fix
Upgrade to a fixed version: Tendermint-Light-Client-Js Project Tendermint-Light-Client-Js 0.28.0; Tendermint-Light-Client-Verifier Project Tendermint-Light-Client-Verifier 0.28.0; Tendermint-Light-Client Project Tendermint-Light-Client 0.28.0. Check the vendor advisory for mitigations.
References
- https://github.com/informalsystems/tendermint-rs/security/advisories/GHSA-xqqc-c5gw-c5r5
- https://github.com/informalsystems/tendermint-rs/security/advisories/GHSA-xqqc-c5gw-c5r5
Get alerted when CVE-2022-23507 or the next vulnerability affects your stack