What’s Vulnerable › Vulnerabilities
CVE-2022-23512: Metersphere is vulnerable to Path Injection.
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-22
Description
MeterSphere is a one-stop open source continuous testing platform. Versions prior to 2.4.1 are vulnerable to Path Injection in ApiTestCaseService::deleteBodyFiles which takes a user-controlled string id and passes it to ApiTestCaseService, which uses the user-provided value (testId) in new File(BODY_FILE_DIR + "/" + testId), being deleted later by file.delete(). By adding some camouflage parameters to the url, an attacker can target files on the server. The vulnerability has been fixed in v2.4.1.
Affected products
- metersphere: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: metersphere 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/metersphere/metersphere/security/advisories/GHSA-5mwp-xw7p-5j27
- https://github.com/metersphere/metersphere/security/advisories/GHSA-5mwp-xw7p-5j27
Get alerted when CVE-2022-23512 or the next vulnerability affects your stack