What’s Vulnerable › Vulnerabilities

CVE-2022-23518: Improper neutralization of data URIs allows XSS in rails-html-sanitizer

Description

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Versions >= 1.0.3, < 1.4.4 are vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0. This issue is patched in version 1.4.4.

Affected products

How to fix

Upgrade to a fixed version: flavorjones loofah 2.19.1; rails-html-sanitizer 1.4.4; Rubygems Rails-Html-Sanitizer 1.4.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-23518 or the next vulnerability affects your stack