What’s Vulnerable › Vulnerabilities
CVE-2022-23520: rails-html-sanitizer contains an incomplete fix for an XSS vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Prior to version 1.4.4, there is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer due to an incomplete fix of CVE-2022-32209. Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags to allow both "select" and "style" elements. Code is only impacted if allowed tags are being overridden. This issue is patched in version 1.4.4. All users overriding the allowed tags to include both "select" and "style" should either upgrade or use this workaround: Remove either "select" or "style" from the overridden allowed tags. NOTE: Code is _not_ impacted if allowed tags are overridden using either the :tags option to the Action View helper method sanitize or the :tags option to the instance method SafeListSanitizer#sanitize.
Affected products
- Debian Linux: 10.0
- rails-html-sanitizer: before 1.4.4 — fixed in 1.4.4
- Rubygems Rails-Html-Sanitizer: before 1.4.4; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0 (+6) — fixed in 1.4.4
How to fix
Upgrade to a fixed version: rails-html-sanitizer 1.4.4; Rubygems Rails-Html-Sanitizer 1.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails-html-sanitizer/security/advisories/GHSA-rrfc-7g8p-99q8
- https://hackerone.com/reports/1654310
- https://lists.debian.org/debian-lts-announce/2023/09/msg00012.html
- https://github.com/rails/rails-html-sanitizer/security/advisories/GHSA-rrfc-7g8p-99q8
- https://hackerone.com/reports/1654310
- https://lists.debian.org/debian-lts-announce/2023/09/msg00012.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00045.html
Get alerted when CVE-2022-23520 or the next vulnerability affects your stack