What’s Vulnerable › Vulnerabilities
CVE-2022-23523: rust-vmm linux-loader vulnerable to Out-of-bounds Read
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-119
Description
In versions prior to 0.8.1, the linux-loader crate uses the offsets and sizes provided in the ELF headers to determine the offsets to read from. If those offsets point beyond the end of the file this could lead to Virtual Machine Monitors using the `linux-loader` crate entering an infinite loop if the ELF header of the kernel they are loading was modified in a malicious manner. This issue has been addressed in 0.8.1. The issue can be mitigated by ensuring that only trusted kernel images are loaded or by verifying that the headers do not point beyond the end of the file.
Affected products
- rust-vmm linux-loader: before 0.8.1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: rust-vmm linux-loader 0.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/rust-vmm/linux-loader/pull/125
- https://github.com/rust-vmm/linux-loader/security/advisories/GHSA-52h2-m2cf-9jh6
- https://github.com/rust-vmm/linux-loader/pull/125
- https://github.com/rust-vmm/linux-loader/security/advisories/GHSA-52h2-m2cf-9jh6
Get alerted when CVE-2022-23523 or the next vulnerability affects your stack