What’s Vulnerable › Vulnerabilities
CVE-2022-23525: Helm vulnerable to Denial of service via NULL Pointer Dereference
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-15 · updated 2026-06-17
- Weakness: CWE-476
Description
Helm is a tool for managing Charts, pre-configured Kubernetes resources. Versions prior to 3.10.3 are subject to NULL Pointer Dereference in the _repo_package. The _repo_ package contains a handler that processes the index file of a repository. For example, the Helm client adds references to chart repositories where charts are managed. The _repo_ package parses the index file of the repository and loads it into structures Go can work with. Some index files can cause array data structures to be created causing a memory violation. Applications that use the _repo_ package in the Helm SDK to parse an index file can suffer a Denial of Service when that input causes a panic that cannot be recovered from. The Helm Client will panic with an index file that causes a memory violation panic. Helm is not a long running service so the panic will not affect future uses of the Helm client. This issue has been patched in 3.10.3. SDK users can validate index files that are correctly formatted before passing them to the _repo_ functions.
Affected products
- helm: from 3.0.0 before 3.10.3 — fixed in 3.10.3
How to fix
Upgrade to a fixed version: helm 3.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/helm/helm/commit/638ebffbc2e445156f3978f02fd83d9af1e56f5b
- https://github.com/helm/helm/security/advisories/GHSA-53c4-hhmh-vw5q
- https://github.com/helm/helm/commit/638ebffbc2e445156f3978f02fd83d9af1e56f5b
- https://github.com/helm/helm/security/advisories/GHSA-53c4-hhmh-vw5q
Get alerted when CVE-2022-23525 or the next vulnerability affects your stack