What’s Vulnerable › Vulnerabilities
CVE-2022-23527: Open Redirect in oidc_validate_redirect_url()
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-601
Description
mod_auth_openidc is an OpenID Certified™ authentication and authorization module for the Apache 2.x HTTP server. Versions prior to 2.4.12.2 are vulnerable to Open Redirect. When providing a logout parameter to the redirect URI, the existing code in oidc_validate_redirect_url() does not properly check for URLs that start with /\t, leading to an open redirect. This issue has been patched in version 2.4.12.2. Users unable to upgrade can mitigate the issue by configuring mod_auth_openidc to only allow redirection when the destination matches a given regular expression with OIDCRedirectURLsAllowed.
Affected products
- Debian Linux: 10.0
- OpenIDC mod_auth_openidc: before 2.4.12.2 — fixed in 2.4.12.2
How to fix
Upgrade to a fixed version: OpenIDC mod_auth_openidc 2.4.12.2. Check the vendor advisory for mitigations.
References
- https://github.com/zmartzone/mod_auth_openidc/blob/v2.4.12.1/auth_openidc.conf#L975-L984
- https://github.com/zmartzone/mod_auth_openidc/security/advisories/GHSA-q6f2-285m-gr53
- https://lists.debian.org/debian-lts-announce/2023/07/msg00020.html
- https://github.com/zmartzone/mod_auth_openidc/blob/v2.4.12.1/auth_openidc.conf#L975-L984
- https://github.com/zmartzone/mod_auth_openidc/security/advisories/GHSA-q6f2-285m-gr53
- https://lists.debian.org/debian-lts-announce/2023/07/msg00020.html
Get alerted when CVE-2022-23527 or the next vulnerability affects your stack