What’s Vulnerable › Vulnerabilities
CVE-2022-23537: PJSIP vulnerable to heap buffer overflow when decoding STUN message
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-20 · updated 2026-06-17
- Weakness: CWE-122
Description
PJSIP is a free and open source multimedia communication library written in C language implementing standard based protocols such as SIP, SDP, RTP, STUN, TURN, and ICE. Buffer overread is possible when parsing a specially crafted STUN message with unknown attribute. The vulnerability affects applications that uses STUN including PJNATH and PJSUA-LIB. The patch is available as a commit in the master branch (2.13.1).
Affected products
- Debian Linux: 10.0
- teluu pjsip: before 2.13.1 — fixed in 2.13.1
How to fix
Upgrade to a fixed version: teluu pjsip 2.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/d8440f4d711a654b511f50f79c0445b26f9dd1e1
- https://github.com/pjsip/pjproject/security/advisories/GHSA-9pfh-r8x4-w26w
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
- https://github.com/pjsip/pjproject/commit/d8440f4d711a654b511f50f79c0445b26f9dd1e1
- https://github.com/pjsip/pjproject/security/advisories/GHSA-9pfh-r8x4-w26w
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00030.html
Get alerted when CVE-2022-23537 or the next vulnerability affects your stack