What’s Vulnerable › Vulnerabilities
CVE-2022-23542: OpenFGA Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-20 · updated 2026-06-17
- Weakness: CWE-285
Description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. During an internal security assessment, it was discovered that OpenFGA version 0.3.0 is vulnerable to authorization bypass under certain conditions. This issue has been patched in version 0.3.1 and is backward compatible.
Affected products
- openfga: before 0.3.1 — fixed in 0.3.1
How to fix
Upgrade to a fixed version: openfga 0.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/pull/422
- https://github.com/openfga/openfga/releases/tag/v0.3.1
- https://github.com/openfga/openfga/security/advisories/GHSA-m3q4-7qmj-657m
- https://github.com/openfga/openfga/pull/422
- https://github.com/openfga/openfga/releases/tag/v0.3.1
- https://github.com/openfga/openfga/security/advisories/GHSA-m3q4-7qmj-657m
Get alerted when CVE-2022-23542 or the next vulnerability affects your stack