What’s Vulnerable › Vulnerabilities
CVE-2022-23546: Discourse vulnerable to private topic leak via email#send_digest
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-05 · updated 2026-06-17
- Weakness: CWE-200
Description
In version 2.9.0.beta14 of Discourse, an open-source discussion platform, maliciously embedded urls can leak an admin's digest of recent topics, possibly exposing private information. A patch is available for version 2.9.0.beta15. There are no known workarounds for this issue.
Affected products
- discourse: before 2.9.0; 2.9.0-beta1, 2.9.0-beta10, 2.9.0-beta11, 2.9.0-beta12, 2.9.0-beta13, 2.9.0-beta14 (+7) — fixed in 2.9.0
How to fix
Upgrade to a fixed version: discourse 2.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/cf862e736565c6fa905c12b5dbe63d0bd056efb8
- https://github.com/discourse/discourse/security/advisories/GHSA-q9jp-xv4g-328f
- https://github.com/discourse/discourse/commit/cf862e736565c6fa905c12b5dbe63d0bd056efb8
- https://github.com/discourse/discourse/security/advisories/GHSA-q9jp-xv4g-328f
Get alerted when CVE-2022-23546 or the next vulnerability affects your stack