What’s Vulnerable › Vulnerabilities
CVE-2022-23547: Heap buffer overflow in pjproject when decoding STUN message
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-23 · updated 2026-06-17
- Weakness: CWE-122
Description
PJSIP is a free and open source multimedia communication library written in C language implementing standard based protocols such as SIP, SDP, RTP, STUN, TURN, and ICE. This issue is similar to GHSA-9pfh-r8x4-w26w. Possible buffer overread when parsing a certain STUN message. The vulnerability affects applications that uses STUN including PJNATH and PJSUA-LIB. The patch is available as commit in the master branch.
Affected products
- Pjsip: before 2.13.1 — fixed in 2.13.1
How to fix
Upgrade to a fixed version: Pjsip 2.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/bc4812d31a67d5e2f973fbfaf950d6118226cf36
- https://github.com/pjsip/pjproject/security/advisories/GHSA-9pfh-r8x4-w26w
- https://github.com/pjsip/pjproject/security/advisories/GHSA-cxwq-5g9x-x7fr
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
- https://github.com/pjsip/pjproject/commit/bc4812d31a67d5e2f973fbfaf950d6118226cf36
- https://github.com/pjsip/pjproject/security/advisories/GHSA-9pfh-r8x4-w26w
- https://github.com/pjsip/pjproject/security/advisories/GHSA-cxwq-5g9x-x7fr
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00030.html
Get alerted when CVE-2022-23547 or the next vulnerability affects your stack