What’s Vulnerable › Vulnerabilities
CVE-2022-2355: Easy Username Updater < 1.0.5 - Arbitrary Username Update via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The Easy Username Updater WordPress plugin before 1.0.5 does not implement CSRF checks, which could allow attackers to make a logged in admin change any user's username includes the admin
Affected products
- Easy Username Updater: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Easy Username Updater 1.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/426b5a0f-c16d-429a-9396-b3aea7922826
- https://wpscan.com/vulnerability/426b5a0f-c16d-429a-9396-b3aea7922826
Get alerted when CVE-2022-2355 or the next vulnerability affects your stack