What’s Vulnerable › Vulnerabilities
CVE-2022-23592: Out of bounds read in Tensorflow
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-04 · updated 2026-06-17
- Weakness: CWE-125
Description
Tensorflow is an Open Source Machine Learning Framework. TensorFlow's type inference can cause a heap out of bounds read as the bounds checking is done in a `DCHECK` (which is a no-op during production). An attacker can control the `input_idx` variable such that `ix` would be larger than the number of values in `node_t.args`. The fix will be included in TensorFlow 2.8.0. This is the only affected version.
Affected products
- tensorflow: from 2.7.0 before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: tensorflow 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/core/graph/graph.cc#L223-L229
- https://github.com/tensorflow/tensorflow/commit/c99d98cd189839dcf51aee94e7437b54b31f8abd
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq36-27g6-p492
- https://github.com/tensorflow/tensorflow/blob/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/core/graph/graph.cc#L223-L229
- https://github.com/tensorflow/tensorflow/commit/c99d98cd189839dcf51aee94e7437b54b31f8abd
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq36-27g6-p492
Get alerted when CVE-2022-23592 or the next vulnerability affects your stack