What’s Vulnerable › Vulnerabilities

CVE-2022-23598: Reflected XSS vulnerability when rendering error messages in laminas-form

Description

laminas-form is a package for validating and displaying simple and complex forms. When rendering validation error messages via the `formElementErrors()` view helper shipped with laminas-form, many messages will contain the submitted value. However, in laminas-form prior to version 3.1.1, the value was not being escaped for HTML contexts, which could potentially lead to a reflected cross-site scripting attack. Versions 3.1.1 and above contain a patch to mitigate the vulnerability. A workaround is available. One may manually place code at the top of a view script where one calls the `formElementErrors()` view helper. More information about this workaround is available on the GitHub Security Advisory.

Affected products

How to fix

Upgrade to a fixed version: Getlaminas Laminas-Form 2.17.1, 3.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-23598 or the next vulnerability affects your stack