What’s Vulnerable › Vulnerabilities
CVE-2022-23602: Nim's rst parser sandboxed mode allows include which can embed any local file
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-22
Description
Nimforum is a lightweight alternative to Discourse written in Nim. In versions prior to 2.2.0 any forum user can create a new thread/post with an include referencing a file local to the host operating system. Nimforum will render the file if able. This can also be done silently by using NimForum's post "preview" endpoint. Even if NimForum is running as a non-critical user, the forum.json secrets can be stolen. Version 2.2.0 of NimForum includes patches for this vulnerability. Users are advised to upgrade as soon as is possible. There are no known workarounds for this issue.
Affected products
- nim-lang Docutils: before 1.6.2 — fixed in 1.6.2
- nim-lang Nimforum: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: nim-lang Docutils 1.6.2; nim-lang Nimforum 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/nim-lang/Nim/commit/cb894c7094fb49014f85815a9dafc38b5dda743e
- https://github.com/nim-lang/nimforum/security/advisories/GHSA-q3vh-x957-wr75
- https://github.com/nim-lang/Nim/commit/cb894c7094fb49014f85815a9dafc38b5dda743e
- https://github.com/nim-lang/nimforum/security/advisories/GHSA-q3vh-x957-wr75
Get alerted when CVE-2022-23602 or the next vulnerability affects your stack