What’s Vulnerable › Vulnerabilities
CVE-2022-23607: Unsafe handling of user-specified cookies in treq
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-200
Description
treq is an HTTP library inspired by requests but written on top of Twisted's Agents. Treq's request methods (`treq.get`, `treq.post`, etc.) and `treq.client.HTTPClient` constructor accept cookies as a dictionary. Such cookies are not bound to a single domain, and are therefore sent to *every* domain ("supercookies"). This can potentially cause sensitive information to leak upon an HTTP redirect to a different domain., e.g. should `https://example.com` redirect to `http://cloudstorageprovider.com` the latter will receive the cookie `session`. Treq 2021.1.0 and later bind cookies given to request methods (`treq.request`, `treq.get`, `HTTPClient.request`, `HTTPClient.get`, etc.) to the origin of the *url* parameter. Users are advised to upgrade. For users unable to upgrade Instead of passing a dictionary as the *cookies* argument, pass a `http.cookiejar.CookieJar` instance with properly domain- and scheme-scoped cookies in it.
Affected products
- Debian Linux: 9.0
- Twistedmatrix Treq: from 21.1.0 before 22.1.0 — fixed in 22.1.0
How to fix
Upgrade to a fixed version: Twistedmatrix Treq 22.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/twisted/treq/security/advisories/GHSA-fhpf-pp6p-55qc
- https://lists.debian.org/debian-lts-announce/2022/03/msg00025.html
- https://github.com/twisted/treq/security/advisories/GHSA-fhpf-pp6p-55qc
- https://lists.debian.org/debian-lts-announce/2022/03/msg00025.html
Get alerted when CVE-2022-23607 or the next vulnerability affects your stack